Topnod för Schemaläggaren

Schemaläggaren

Du kan använda Schemaläggaren till att schemalägga kommandon, program eller skript vid speciella tidpunkter:

  • Innan du använder Schemaläggaren bör du läsa avsnittet Checklista.
  • Om du vill ha hjälp med speciella aktiviteter hittar du det i avsnittet Hur gör jag?.
  • Allmän bakgrundsinformation finns i Begrepp.
  • Hjälp med felsökning finns i Felsökning.


Checklista för Schemaläggaren

Checklista

I följande tabell finns en lista över de åtgärder som du oftast utför med Schemaläggaren. En fullständig lista över instruktionerna till Schemaläggaren finns i Hur gör jag?.

Steg | Referens
Innan du kan schemalägga körningen av en aktivitet måste du lägga till aktiviteten. | Schemalägga en ny aktivitet
När schemalagda aktiviteter väl har skapats kan du ändra programmet, schemat eller egenskaperna för en särskild aktivitet. | Ändra en schemalagd aktivitet
Om det finns schemalagda aktiviteter som inte längre behövs, kan du ta bort dem helt och hållet. | Ta bort en schemalagd aktivitet
Om en schemalagd aktivitet startar medan du använder datorn, kan du avsluta aktiviteten och sedan starta om den senare. | Avsluta en schemalagd aktivitet som är igång
Du kan tillfälligt avsluta eller pausa alla schemalagda aktiviteter och sedan starta dem igen vid ett senare tillfälle. | Tillfälligt avsluta alla schemalagda aktiviteter


Hur gör jag?

  • Schemalägga aktiviteter
  • Hantera Schemaläggaren


Schemalägga aktiviteter
  • Starta Schemaläggaren
  • Schemalägga en ny aktivitet
  • Ändra en schemalagd aktivitet
  • Ta bort en schemalagd aktivitet
  • Avsluta en schemalagd aktivitet som är igång
  • Köra en aktivitet omedelbart


Starta Schemaläggaren

Så här startar du Schemaläggaren

  • Du kan starta Schemaläggaren genom att först dubbelklicka på Den här datorn och därefter på Schemalagda aktiviteter.
  • Dubbelklicka på Schemalagda aktiviteter och därefter på Lägg till en schemalagd aktivitet. Då öppnas guiden Lägg till schemalagd aktivitet, där du får hjälp med att schemalägga en aktivitet.


Schemalägga en ny aktivitet

Så här schemalägger du en ny aktivitet
  1. Starta Schemaläggaren.
  2. Dubbelklicka på Lägg till en schemalagd aktivitet.
  3. Följ instruktionerna i guiden Lägg till schemalagd aktivitet.

Obs!

  • Om du vill konfigurera avancerade inställningar för aktiviteten, markerar du kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför i guidens slutbild.
  • Om du vill att körningen av en ny aktivitet ska upprepas flera gånger varje gång den körs, markerar du kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför i den sista bilden av guiden. Klicka därefter på fliken Schema och på Avancerat.
  • Om aktivitetens program kräver parametrar, markerar du kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför i slutbilden av guiden. Klicka därefter på fliken Aktivitet och skriv in dem i Kör, efter aktivitetens sökväg.
  • Kontrollera att systemdatum och systemtid på din dator stämmer. Det är den informationen som Schemaläggaren går efter när schemalagda aktiviteter ska köras. När du vill kontrollera datum och tid, klickar du på tiden i Aktivitetsfältet.


Ändra en schemalagd aktivitet

Så här ändrar du en schemalagd aktivitet
  1. Starta Schemaläggaren.
  2. Högerklicka på den aktivitet som du vill ändra och klicka sedan på Egenskaper.
  3. Utför en eller flera av följande åtgärder:
    • Om du vill byta det program som just körs, skriver du in sökvägen för det nya programmet i Kör.
    • Om du vill ändra schemaläggningen för aktiviteten, klickar du på fliken Schema.
    • Om du vill anpassa inställningarna för aktiviteten, klickar du på fliken Inställningar.

Obs!

  • Om du ändrar användarkontot eller det program som är igång, måste du ange lösenordet för användarkontot.
  • Om aktivitetens program kräver kommandoradsalternativ skriver du in dem i Kör, efter aktivitetens sökväg.
  • Om sökvägen till aktivitetens program innehåller blanksteg, sätter du hela sökvägen inom citattecken ("").
  • Kontrollera att systemdatum och systemtid i din dator stämmer, för det är den här informationen som Schemaläggaren går efter när schemalagda aktiviteter ska köras. När du vill kontrollera eller ändra datum och tid, klickar du på tidsindikatorn i Aktivitetsfältet.


Ta bort en schemalagd aktivitet

Så här tar du bort en schemalagd aktivitet
  1. Starta Schemaläggaren.
  2. Högerklicka på den aktivitet som du vill ta bort och klicka sedan på Ta bort.

Obs!

  • När du tar bort en schemalagd aktivitet är det bara själva schemaläggningen som tas bort från listan över schemaläggningar. Programfilen tas inte bort från hårddisken.
  • Det går också att ta bort en schemalagd aktivitet genom att trycka på DELETE.


Avsluta en schemalagd aktivitet som är igång

Så här avslutar du en schemalagd aktivitet som är igång
  1. Starta Schemaläggaren.
  2. Högerklicka på den aktivitet som du vill avsluta och klicka sedan på Avsluta aktivitet.

Obs!

  • Om ett annat program startas via en schemalagd uppgift är det bara den ursprungliga schemalagda uppgiften som avslutas, inte den andra aktiviteten.
  • Om du vill starta en avbruten aktivitet igen, högerklickar du på den och klickar sedan på Kör.


Köra en aktivitet omedelbart

Så här kör du en aktivitet omedelbart
  1. Starta Schemaläggaren.
  2. Högerklicka på den aktivitet som du vill starta och klicka sedan på Kör.

Obs!

  • Det går att avsluta aktiviteten genom att klicka på Avsluta aktivitet på Arkiv-menyn.
  • Om en aktivitet skulle ha körts men inte kördes, klickar du på Visa logg på Avancerat-menyn och kan då undersöka aktivitetsloggen.


Hantera Schemaläggaren
  • Visa en logg över tidigare schemalagda aktiviteter
  • Visa schemalagda aktiviteter på fjärrdatorer
  • Tillfälligt avsluta alla schemalagda aktiviteter
  • Pausa Schemaläggaren
  • Ställa in AT-tjänstkontot


Visa en logg över tidigare schemalagda aktiviteter

Så här visar du en logg över tidigare schemalagda aktiviteter
  1. Starta Schemaläggaren.
  2. Klicka på Visa logg på Avancerat-menyn.


Visa schemalagda aktiviteter på fjärrdatorer

Så här visar du schemalagda aktiviteter på fjärrdatorer
  1. Dubbelklicka på Nätverket på skrivbordet.
  2. Dubbelklicka på den dator som du vill visa de schemalagda aktiviteterna på.
  3. Klicka på Schemalagda aktiviteter.

Obs!

  • Du kan bara visa aktiviteter på en fjärrdator som kör Windows om du är administratör för fjärrdatorn.
  • Du kan bara redigera aktiviteter på en annan dator som kör Windows om den datorn har installerat programvara för fjärregister och delar x$-resursen, där x är den hårddisk där mappen Schemalagda aktiviteter finns. På den datorn som kör Windows måste det också finnas en lista som anger att ditt användarkonto har fjärregisterbehörighet. Genom att klicka på Lösenord i Kontrollpanelen, kan du ange vilka användare som har fjärregisterbehörighet till en dator som kör Windows.


Tillfälligt avsluta alla schemalagda aktiviteter

Så här avslutar du tillfälligt alla schemalagda aktiviteter
  1. Starta Schemaläggaren.

  2. Klicka på Pausa Schemaläggaren på Avancerat-menyn.

Obs!

  • Det här kommandot kan vara bra att använda när du kör ett annat program (till exempel ett spel) eller håller på att installera en programvara och inte vill att schemalagda aktiviteter ska köras på samma gång.
  • De aktiviteter som skulle ha körts under paustiden, körs inte förrän nästa schemalagda tillfälle infaller.
  • När du vill fortsätta schemaläggningen för alla aktiviteter, klickar du på Fortsätt med Schemaläggaren på Avancerat-menyn.


Pausa Schemaläggaren.

Så här pausar du Schemaläggaren
  1. Starta Schemaläggaren.
  2. Klicka på Inaktivera Schemaläggaren på Avancerat-menyn.

Obs!

  • När du stänger av Schemaläggaren, körs inte de schemalagda aktiviteterna och Schemaläggaren startar inte automatiskt nästa gång som du startar Windows.


Ställa in AT-tjänstkontot

Så här ställer du in AT-tjänstkontot
  1. Starta Schemaläggaren.
  2. Klicka på AT-tjänstkonto på Avancerat-menyn.
  3. Klicka på Detta konto och skriv sedan in det användarkonto som ska köra aktiviteter som har schemalagts med hjälp av kommandot AT.
  4. Skriv in rätt lösenord för kontot i rutorna Lösenord och Bekräfta lösenord.

Obs!

  • AT-tjänst är bara tillgängligt på Windows NT.
  • Du kan också välja att klicka på Systemkonto. Om du gör det kommer Schemaläggaren att köra AT-aktiviteterna med hjälp av LocalSystem-kontot, vilket kräver administratörsbehörigheter.

  • Det användarkonto som du anger måste ha rätt behörigheter för att kunna köra aktiviteter som du schemalägger med kommandot AT. Om du till exempel schemalägger program som bara kan köras av administratörer, måste det användarkonto som du anger vara ett administratörskonto.


Begrepp i Schemaläggaren

Begrepp

I det här avsnittet finns allmän bakgrundsinformation om Schemaläggaren:

  • Introduktion till Schemaläggaren
  • Använda Schemaläggaren
  • Schemaläggaren och kommandot AT
  • Säkerheten i Schemaläggaren
  • Felsökning


Introduktion till Schemaläggaren

Med hjälp av Schemaläggaren kan du schemalägga aktiviteter (till exempel Diskdefragmenteraren) så att de körs på tider då det passar dig bäst. Schemaläggaren startar varje gång du startar Windows och programmet körs i bakgrunden.

Med Schemaläggaren kan du göra följande:

  • Schemalägga en aktivitet så att den körs varje dag, varje vecka, varje månad eller på vissa tider (till exempel vid systemstart).
  • Ändra schema för en aktivitet.
  • Avsluta en schemalagd aktivitet.
  • Anpassa körningen av en aktivitet på en schemalagd tid.


Använda Schemaläggaren

Schemaläggaren installeras automatiskt i Windows. Om du vill använda schemaläggningstjänsten dubbelklickar du på mappen Schemalagda aktiviteter i Den här datorn.

Du kan lägga till aktiviteter genom att dubbelklicka på Lägg till en schemalagd aktivitet. Då startas guiden Schemalagda aktiviteter. Du kan lägga till aktiviteter genom att dra skript, program eller dokument från Utforskaren eller skrivbordet till fönstret Schemalagda aktiviteter.

Du kan också använda Schemaläggaren när du vill ändra, ta bort, pausa eller avsluta aktiviteter som du har schemalagt, när du vill visa en logg över tidigare schemalagda aktiviteter eller om du vill visa aktiviteter som är schemalagda på en annan dator.

Detaljerade instruktioner om hur du använder Schemaläggaren finns i Hur gör jag?.

Goda råd om Schemaläggaren

I Windows kan du använda Schemaläggaren för att schemalägga körningen av vilket program som helst. För att du ska få ut mesta möjliga av Schemaläggaren, är det viktigt att du kontrollerar att systemdatum och systemtid i datorn stämmer innan du lägger in en aktivitet.


Använda Schemaläggaren och kommandot AT

Schemaläggaren och kommandot AT

Förutom Schemaläggaren kan du också använda kommandot AT för att köra aktiviteter automatiskt.

Schemaläggaren är inte samma sak som kommandot AT men de fungerar tillsammans. När du schemalägger en aktivitet med hjälp av kommandot AT, visas det i aktivitetslistan i fönstret Schemaläggaren.

Du kan använda Schemaläggaren när du vill ändra egenskaperna för en aktivitet som har schemalagts med kommandot AT. Om du gör det måste du dock fortsätta att använda Schemaläggaren för att ha tillgång till aktiviteten. Du kan inte längre komma åt den via kommandot AT.

När du ska ange vilket användarkonto som ska köra aktiviteter som har schemalagts med kommandot AT, klickar du på Schemalagda aktiviteter i Den här datorn och därefter på AT-tjänstkonto på Avancerat-menyn.

Obs!

  • AT-tjänst är bara tillgängligt på Windows NT.


Säkerhetstjänster för Schemaläggaren

Säkerheten i Schemaläggaren

I Schemaläggaren kan du öka säkerheten genom att tilldela ett användarnamn och ett lösenord till en viss aktivitet. När ett användarnamn och ett lösenord har angetts kan aktiviteten inte avbrytas eller tas bort av någon annan användare.

Obs!

  • Den här säkerhetsfunktionen är bara tillgänglig på Windows NT.
  • Du måste ange ett användarnamn i guiden Lägg till schemalagd aktivitet innan du kan fortsätta schemaläggningen av en aktivitet. Det krävs inga lösenord.
  • Du kan ändra lösenord eller ange ett nytt lösenord genom att markera kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför i guidens slutbild.


Felsökning i Schemaläggaren

Om aktiviteten inte körs när den borde köras, högerklickar du på aktiviteten och klickar sedan på Egenskaper. Kontrollera att kryssrutan Aktiverad på fliken Aktivitet är markerad. Kontrollera att schemat har angetts rätt på fliken Schema.

Om programmet inte körs riktigt kanske du måste lägga till kommandoradsalternativ. Om du vill ta reda på mer om ett särskilt program och dess kommandoradsalternativ, kan du pröva något av följande:

  • Läs i programmets direkthjälp om det finns någon sådan.

  • Skriv in följande vid en DOS-prompt: (där program är programmets namn)

    • program /?


Komponent i Windows NT ej installerad

Programmet startade inte

Möjliga orsaker är följande:

    • Programmet har tagits bort av en systemadministratör.
    • Systemadministratören har ändrat principen som är kopplad till filen.
    • Programmet har inte installerats på datorn.
    • Programmet har av misstag tagits bort.
    • Filen är felaktig.

Om det är en systemadministratör som sköter datorn, bör du kontakta denne för att få reda på varför du inte kan starta programmet.